Yes, you will need to verify that any computer that will be used to access NexusConnect has the following software and version minimums:

  • Internet Explorer 9.0 or Higher
  • Access to the Internet